Menus
This article concerns the
macOS
app.
See other variants:
Windows

Note that this section only covers Texifier-specific menu items that have not been covered above. The usual Mac OS menu items behave as expected.

The Texifier Menu

Menu Option Explanation Key Shortcut
Texifier About Texifier Information, legal statement and credits.
Texifier Texifier for iPad/iPod/iPhone A link to the iOS version of Texifier.
Texifier Preferences Settings and preferences window. Cmd-,
Texifier Add/Edit Autocompleted Commands… Opens the directory where auto-complete commands can be customised.

The File Menu

Menu Option Explanation Key Shortcut
File New From Template Create a new .tex document from a template.
File Add/Edit templates… View the directory where the templates are stored ~/Library/Application Support/Texifier/Templates/. Any files added to this directory are automatically listed in the File New From Template menu by Texifier.
File Reveal PDF in Finder Opens the macOS Finder where the output PDF file is stored. Cmd-R
File Email PDF Open a new email message with the current PDF file as an attachment. Cmd-E
File File Encoding Choose the file encoding Texifier should use for loading and saving files. If you alter the file encoding with open documents, Texifier will migrate all files in the project, and save to disc. We strongly recommend that you use UTF-8 file encoding for your work; it supports all languages, and as such it is becoming a de facto standard for plain text files.

docs/apps/workspace/menus/encodings-menu_macos.png
File Reload with File Encoding If you see strange characters, there is a good chance you have opened a file with the incorrect encoding; this option will discard all changes and reload all open files using the specified character encoding.
File Print LaTeX Source… Prints the source code. Alt-Cmd-P
File Print PDF… Prints the PDF. Cmd-P

The Edit Menu

Menu Option Explanation Key Shortcut
Edit Comment Block and Edit Uncomment Block These menu options will comment or uncomment an entire block of text in one go. Cmd-/ will toggle between the commented & uncommented state.
Edit Indent Block and Edit Unindent Block These menu options will indent or unindent an entire block of text. Shift-Cmd-] and Shift-Cmd-[ respectively.
Edit Autocomplete Force-opens the auto-complete window in the editor for the currently typed word. Esc
Edit Global Search Brings into focus the global search field on the top of the window. Shift-Cmd-F

The Snippets Menu

The menu lists all the currently deployed snippets in the snippets’ directory that may be opened by selecting Add/Edit Snippets….

docs/apps/workspace/menus/snippets_macos.png

The Typeset Menu

See the help article on the Texifier Toolbar for details on various typesetters and their use.

Menu Option Explanation Key Shortcut
Typeset Normal Runs the (non-live) manual typeset Cmd-T
Typeset Add/Edit Global .tpbuild Scripts Opens directory BuildScripts containing all currently installed global .tpbuild scripts.
Typeset Toggle Auto-typeset Switches on and off the auto-typeset for the current project. Shift-Cmd-L
Typeset Remove Intermediate Files If the Hide intermediate files option is selected, Texifier keeps your home file uncluttered by hiding the intermediate files such as .aux, .log, etc. in a hidden directory called .texpadtmp. Selecting this menu option deletes this hidden directory. Note that this is safe operation and is sometimes necessary to remove possibly corrupted .aux files. Cmd-K
Typeset Abort Typesetting This will abort typesetting if in progress. Cmd-.

The Window Menu

Menu Option Explanation Key Shortcut
Window Show Welcome Window Displays the Texifier welcome window. Ctrl-Cmd-T
Window Zoom In & Zoom Out Zoom in/out for the PDF pane. Cmd-+ and Cmd-- respectively
Window Toggle Outline Shows/hide the Outline View. Cmd-1
Window Hiding/showing View Panes Menu items to change arrangement of the editor between Editor only, Editor and Output, and Output only respectively. Cmd-2, Cmd-3 & Cmd-4 respectively
Window Switch between PDF and Log Output Allows you to switch the output pane between the PDF view and the Error log. Cmd-8 & Cmd-9 respectively